戻る
■PHPを5.6にバージョンアップ
PHP5.3をPHP5.6にする手順 AWS EC2 で始めるお手軽LAMP環境 APACHE2.4 MYSQL5.5 PHP5.6 http://qiita.com/bboobbaa/items/62761fc219136c37af14 Amazon Linux AMIでPHPを5.3から5.4にアップグレードする方法 with FuelPHP http://qiita.com/Keech/items/70593f432008dc89c2e8 AWS EC2 Amazon LinuxでphpMyAdminを動かす方法!mysqli|mysql 拡張がありません。って http://yutaihara.com/archives/240 ■インストール済みのバージョンを確認 # httpd -v … Apacheのバージョンを確認 Server version: Apache/2.2.31 (Unix) Server built: Jul 19 2016 00:11:31 # php -v … PHPのバージョンを確認 PHP 5.3.29 (cli) (built: May 12 2015 22:42:19) Copyright (c) 1997-2014 The PHP Group Zend Engine v2.3.0, Copyright (c) 1998-2014 Zend Technologies # yum list installed | grep php … PHP関連のモジュールを確認 php.x86_64 5.3.29-1.8.amzn1 @amzn-main php-cli.x86_64 5.3.29-1.8.amzn1 @amzn-main php-common.x86_64 5.3.29-1.8.amzn1 @amzn-main php-devel.x86_64 5.3.29-1.8.amzn1 @amzn-main php-gd.x86_64 5.3.29-1.8.amzn1 @amzn-main php-mbstring.x86_64 5.3.29-1.8.amzn1 @amzn-main php-mysql.x86_64 5.3.29-1.8.amzn1 @amzn-main php-pdo.x86_64 5.3.29-1.8.amzn1 @amzn-main php-pear.noarch 1:1.10.1-1.19.amzn1 @amzn-main php-process.x86_64 5.3.29-1.8.amzn1 @amzn-main php-xml.x86_64 5.3.29-1.8.amzn1 @amzn-main ■古いバージョンをアンインストール # cp /etc/httpd/conf/httpd.conf /etc/httpd/conf/httpd.conf.20170525 … Apacheの設定ファイルをバックアップ # cp /etc/php.ini /etc/php.ini.20170525 … PHPの設定ファイルをバックアップ # yum remove httpd-* … Apacheをアンインストール(PHP5.4以降ではApache2.4とセットで使う…と思っていたが、2.2でも動くみたい) # yum remove php … PHPをアンインストール # yum remove php* # yum remove php-* # yum clean all … 念のためyumのキャッシュを削除 ■インストール # yum -y install httpd24 … Apache2.4をインストール # yum -y install php56 php56-mbstring php56-gd … PHP5.6をインストール(必要に応じてGDなどもインストール。あらかじめ確認しておくこと) # php -v # vi /etc/php.ini # service httpd start … httpdを起動 # chkconfig httpd on … httpdの自動起動を設定 ■MySQLを使っている場合 # yum -y install php56-mysqlnd … php-mysqlをインストール(「php56-mysql」などはダメだった / EC2以外なら大丈夫かも) # service httpd restart … httpdを再起動